[Date Prev][Date Next][Thread Prev][Thread Next][Author Index][Date Index][Thread Index]
Re: Protocols for Smashing the State
- To: <mark>, <michael>, <ravi>
- Subject: Re: Protocols for Smashing the State
- From: Bill Richard <wjr>
- Date: Mon, 13 Nov 89 09:28:38 PST
- Cc: <xanatech>
>From michael Mon Nov 13 06:52:01 1989
Abstract: For once I argue for terseness.
> From mark Mon Nov 13 04:53:48 1989
> I don't at all like "merge". What would be ideal would be a name
> had the same relation to "union" that "+=" had to "+". It'd be
> if this turned into a general naming convention. How about
> void MuSet::unionInto (Set *)
> with the "Into" suffix being the general convention?
Good idea, but how about "To" as the general convention?
("On" is awkward here, but might make sense even more often. I
any particle will be awkward, though, since the normal way to name a
side-effecting operation is with a verb,
It probably doesn't generalize well but in light of Michael's comment,
I can't resist suggesting "unionize" for this specific case.